You are here: eSignLive Documentation > Product Overview > Security Vulnerability Updates

Security Vulnerability Updates

April 9, 2017: Dropped Support for Medium-Strength Ciphers

eSignLive is committed to protecting the security of its customers' data. As such, on April 9, 2017 it increased the minimum security requirements for connecting to the service. Specifically, this change dropped support for older ciphers that, by today's standards, are considered insecure. This change will require user platforms that connect to the service to support strong ciphers. Users running older platforms or browsers may not be able to connect to the service. Integrated customers still running unsupported Windows 2003 servers may also experience issues connecting to the application's API. Should you experience any issues, please contact Technical Support (support@esignlive.com; 1-855-MYESIGN).

TIP: More information about minimum security requirements is available here.